Sign in to follow this  
Followers 0

Is this Fuel Cut?

7 posts in this topic

Hi guys

I've started to get an issue recently and im not sure if it's fuel cut related. I'm puttin my foot down, the car starts to accelerate, all 3 boost lights come on( 8) ), but then the car seems to judder for a second and I lose all acceleration until I pull my foot off the pedal and put it back down again (although my instinct is to do this straight away so i can't really say if it would stay off or kick back in).

It doesn't seem to happen when I accelerate more gently even to full boost. It's most notable in 2nd gear I guess beause of the revs/boost building up faster but I've had it happen in 5th. 

I've had the car with no previous UK owners so don't have any record of the boost being turned up and wouldnt really have a clue how to check but i've always thought it was standard. It's only started happening recently as well. If it was fuel cut would it have happened from day 1 with the boost turned up from the previous owner?

any help appreciated in finding out what this is :)

Share this post


Link to post
Share on other sites

Sounds like fuel cut, your probably only seeing it now with the cold temperatures, cold air is denser so you will make slightly more boost than a hot day etc, possibly just enough for you to hit fuel cut.

 

you def need a boost gauge in these cars! Keep and eye on things

Share this post


Link to post
Share on other sites

This makes perfect sense as I've had the car from about may.  Yes! a boost gauge sounds like a wise investment.

amazingly quick reply man. Thanks :)

Share this post


Link to post
Share on other sites

Would also try a see when the car judders see if the engine light comes on, would also check what actuator you have on too 

Share this post


Link to post
Share on other sites

My experience of fuel cut was like hitting a brick wall, not juddering. Do a diagnostic check. Info will be on here somewhere 

Share this post


Link to post
Share on other sites

Could also be HT leads mine was doing same thing so i reduced the boost and it went away for a while then came back. Ended up being the HT leads breaking down but it felt just like boost cut. 

Share this post


Link to post
Share on other sites

Appreciate these other responses guys. The engine management light doesn't come on when it happens and I've not ruled out it could be HT leads or plugs so im hoping to replace these asap too.

I've read that way of describing fuel cut before and i wouldnt say this is the same.. first time it happened I actually thought I'd hit a pot hole and it'd popped out of gear somehow.

Im looking more into it as i type but I've noticed today it happens at 4k revs specifically and last time i got a big pop from the exhaust too.

I'm not gonna be driving it daily till this is sorted now as im scared I'll hurt my baby!

 

 

Edited by Jwood91

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0