Jump to content
Sign in to follow this  
Giannis

Glanza boost issue

Recommended Posts

As title....i am a stock ep91 glanza owner

When I push the throttle it boost fine(three lights on tacho an a lot of power and torgue) utlil 5000 5500 rpm the boost lows down (two lights on tacho and less power and torgue)

Any suggestions

Thanks

Share this post


Link to post
Share on other sites
2 hours ago, akyakapotter said:

If it's completely stock it will restrict boost in 1st and 2nd gear untill you bypass the hi low function.

Cheers nick 

It is nothing to do with restriction....it happens to all gears

Thanks

Share this post


Link to post
Share on other sites
44 minutes ago, BMX-RIG said:

Weak actuator?

This is my first suspicion

Does a cracked manifold affects?

Thanks for reply

Share this post


Link to post
Share on other sites

I am currently going through this same problem, I installed a boost gauge just to be sure and it confirms that I am losing boost as soon as that last light comes off, boost drops with it. From factory its 9psi and I am getting that and just as Giannis said around 5k it drops to about 5-6psi.

Please any suggestions.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...