Jump to content
Sign in to follow this  
Reptagon

Grinding sound past 4000rpm

Recommended Posts

I have an NA ep91 which is reasonably modified, the issue is when i reach over 4000rpm i have recently started getting a horrible grinding sound in the engine bay. My thoughts are either cams, a pump, a brearing or a gear box issue. I know its not my gearbox though as ive just swapped my gearbox to a corolla g6 6 speed box and the sound is still there so i dont know what it could be really.

mods: turbo inlet cam, corolla throttle body, corolla intake manifold, coilovers, front strut brace, short shifter, c160 gear box, 15" bbs wheels with 195/50/15, upgraded interior bits and an intake

Share this post


Link to post
Share on other sites

hey bud, is the grinding sound really pretty loud? my old starlet  manual conversion project made a wild grinding sound when i gave it some after I put the manual box in, turned out I'd missed one of those rubber spacer things on one side of the engine mount and i was getting occasional metal to metal contact, makes a horrible sound lol.

Share this post


Link to post
Share on other sites

😂 Just realised who I'm responding to lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...