Jump to content

starlet1991

Club Member
  • Content Count

    92
  • Joined

  • Last visited

1 Follower

About starlet1991

  • Rank
    Member

Profile Information

  • Gender
    Male
  • Location
    malta

Recent Profile Visitors

1458 profile views
  1. I am currently having an issue with no power in the stereo harness. In the plug shown below there is no power in both the constant 12v (yellow wire) and ignition 12v (red wire). I also found the indicated connector in the second photo identical to the one for the stereo. This is located on the drivers side footwell. Checked with meter for continuity and found that both connectors are on the same harness as confirmed continuity. Can anyone confirm if this needs to be connected to anything? Have found no loose plugs nearby. Would appreciate if anyone can post photos.
  2. I am currently having an issue with no power in the stereo harness. In the plug shown below there is no power in both the constant 12v (yellow wire) and ignition 12v (red wire). I also found the indicated connector in the second photo identical to the one for the stereo. This is located on the drivers side footwell. Checked with meter for continuity and found that both connectors are on the same harness as confirmed continuity. Can anyone confirm if this needs to be connected to anything? Have found no loose plugs nearby. Would appreciate if anyone can post photos.
  3. Can anyone share some photos of the oem earthing cables in the engine bay? Gone through a complete engine bay rebuild and need to be sure that all the earthing cables are installed.
  4. Should the release bearing provided with the orc clutch be installed as is? Or do you need to use the retaining spring clip found on the oem release bearing?
  5. Anyone knows what this plug is for? situated under drivers side front headlight
  6. Looking for a set of 550cc injectors
  7. Looking for an aftermarket high flow fuel rail
  8. Can anyone help to locate where these seals from an oem engine gasket set go to?
  9. Currently going through a forged engine assembly with the below specs: - blocked bored to 74.5mm and surface decked - wossner forged pistons - acl bearings - scat rods - arp main cap studs the block has been assembled using engine assembly lube and following tightening torques provided by arp. The assembled crank on block rotated very easily however when the rods and pistons were installed, it seems that there is too much resistance to turn crank. does anyone have an approximate value for torque that would be required by a torqu
  10. Currently going through a forged engine assembly with the below specs: - blocked bored to 74.5mm and surface decked - wossner forged pistons - acl bearings - scat rods - arp main cap studs the block has been assembled using engine assembly lube and following tightening torques provided by arp. The assembled crank on block rotated very easily however when the rods and pistons were installed, it seems that there is too much resistance to turn crank. does anyone have an approximate value for torque that would be required by a torque wrench to rotate an as
  11. Looking for a Set of glanza headlamps in good condition
  12. Looking for a complete turbo kit. Show me what youve got.
×
×
  • Create New...